Перейти к публикации
LIKVINIK

DataLife Engine PM

Рекомендованные сообщения

LIKVINIK

Лазил по форуму нашел как сделать персональную страницу в отдельном шаблоне

Это в index.php

 

if($_GET['subaction']=='userinfo') $tpl->load_template ( 'user_main.tpl' );

 

А это в user_main.tpl

 

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

<html>

<head>

{headers}

</head>

<body class="main">

{AJAX}

<div style="position:relative">

{info}{content}

</div>

</body>

</html>

а вот как сдлеать что оправление ЛС тоже было на отдельной станицу

на что нужно заменить userinfо что бы ЛС тоже также на отдельной странице было?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
blact

еххх, пошла жара МЕго соц сетей на Дле, а по сути, нафига править двиг? [not-aviable=userinfo|pm] , не , не слышал?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
LIKVINIK

еххх, пошла жара МЕго соц сетей на Дле, а по сути, нафига править двиг? [not-aviable=userinfo|pm] , не , не слышал?

 

1. я не делаю соц.сеть

2. мне нужен способ который указан выше, а не твой!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
volfing
Посмотри subaction PM и замени его и шаб другой подключи :/

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
LIKVINIK

Посмотри subaction PM и замени его и шаб другой подключи :/

 

пробовал не катит=(

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
volfing

 

Посмотри subaction PM и замени его и шаб другой подключи :/

 

пробовал не катит=(

 

Все катит, юзай в гугле условия if else

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
LIKVINIK

Я прописал if($_GET['subaction']=='pm') $tpl->load_template ( 'user_pm.tpl' ); ничего не происходит

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
volfing

Я прописал if($_GET['subaction']=='pm') $tpl->load_template ( 'user_pm.tpl' ); ничего не происходит

 

В файле прописал код ?

И у тебя в другом условие должно остаться подключение main.tpl

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
LIKVINIK

 

Я прописал if($_GET['subaction']=='pm') $tpl->load_template ( 'user_pm.tpl' ); ничего не происходит

 

В файле прописал код ?

И у тебя в другом условие должно остаться подключение main.tpl

 

Я это в index.php запихнул и всё=) а что ещё нужно напиши плиз=)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
volfing

user_pm.tpl прописать {content}

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
LIKVINIK

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
{headers}
<link rel="shortcut icon" href="{THEME}/images/favicon.ico" />
<link media="screen" href="{THEME}/style/styles1.css" type="text/css" rel="stylesheet" />
<link media="screen" href="{THEME}/style/engine.css" type="text/css" rel="stylesheet" />
<script type="text/javascript" src="{THEME}/js/libs.js"></script>
</head>
<body class="main">
{AJAX}
<div style="position:relative">
{info}{content}
</div>
</body>
</html>
это я вставил в user_pm.tpl

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость
Эта тема закрыта для публикации сообщений.

×
×
  • Создать...