Перейти к публикации
Faik

Не работают некоторые теги

Рекомендованные сообщения

Faik

В шаблоне login.tpl стоит код

<a href="{registration-link}">Регистрация</a> : <a href="{lostpassword-link}">Забыли пароль?</a>

 

При переходе по ссылке получается http://site.ru/%7Bregistration-link%7D

 

НЕ знаю, может дело в кодировке, или в том, что установил dle 10.2 с мало проверенного сайта.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Gameer

Ссылки не срабатывают. Пропиши вручную. Обновлялся или чисто поставил? Скачай с невекса и посмотри как будет, если все ок, то дело в сборке.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Faik

В ручную прописать не проблема, но причина меня все равно интересует. Мало ли где еще теги работать. Дивжок ставил с нуля. В настройках поставил дефолтный шаблон, ссылки работают.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Gameer

В ручную прописать не проблема, но причина меня все равно интересует. Мало ли где еще теги работать. Дивжок ставил с нуля. В настройках поставил дефолтный шаблон, ссылки работают.

Скачай отсюда. Должно быть все ок. Думаю это из за сборки двига, там много чего могли понапихать, бэкдоров, шелов, ссылок, редиректов.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Faik

Скачал отсюда. Та же проблема. В дефолтном шаблоне работает, в моем нет. Шаблон адаптировал с хтмл, так что мог что-то упустить. Но что именно?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Gameer

Скачал отсюда. Та же проблема. В дефолтном шаблоне работает, в моем нет. Шаблон адаптировал с хтмл, так что мог что-то упустить. Но что именно?

Кинь код login.tpl

 

И еще в maint.tpl есть теги {headers} и {AJAX}

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Faik

 

И еще в maint.tpl есть теги {headers} и {AJAX}

это есть.

 

[not-group=5]
PROFILE
[/not-group]
[group=5]
<form method="post" action="">
<label for="login_name"><input type="text" name="login_name" id="login_name">
<label for="login_password"><input type="password" name="login_password" id="login_password">
<a onclick="submit();" type="submit" class="login_buttom" title="Войти">Войти</a>
<div class="login_links"><a href="{registration-link}">Регистрация</a> : <a href="{lostpassword-link}">Забыли пароль?</a></div>
</form>
    [/group]

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Gameer

@Faik, да все вроде нормально. код нормальный, только нет закрывающих для тега <label>.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Faik

ну странно

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
asmakovec2

[not-group=5]
PROFILE
[/not-group]
[group=5]
<form method="post" action="">
<label for="login_name"><input type="text" name="login_name" id="login_name">
<label for="login_password"><input type="password" name="login_password" id="login_password">
<a onclick="submit();" type="submit" class="login_buttom" title="Войти">Войти</a>
</form>
<div class="login_links"><a href="{registration-link}">Регистрация</a> : <a href="{lostpassword-link}">Забыли пароль?</a></div>
[/group]

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость Blendy

@Faik, Зачем ссылки в ФОРМУ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Faik

Ссылки для регистрации 

И вообще не важно, зачем. Они ведь должны работать.

Изменено пользователем Faik

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость Blendy

@Faik, В форме работать не будут, опусти их ниже формы и проверь.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Faik

@Faik, В форме работать не будут, опусти их ниже формы и проверь.

Не в этом дело. 

[not-group=5]
<li><a href="/admin.php?mod=addnews&action=addnews"><span>Добавить новость</span></a></li>
<li><a href="/admin.php?mod=options&action=options" target="_blank" tooltip="(откроется в новом окне)">Админпанель</a></li>
<li><a href="{profile-link}">Мой профиль</a></li>
<li><a href="/index.php?do=pm">Сообщения</a></li>
<li><a href="/?do=lastcomments">Последние комментарии</a></li>
<li class="last"><a href="/index.php?action=logout"><span>Выход</span></a></li>
[/not-group]

Вот код после авторизации. Формы нет, а ссылка на профиль так же не работает

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость Blendy

@Faik, в каком файле данный код?

O.T.
Список должен лежать в ul или в ol!


@Faik, Вот попробуйте это:

<li><a href="#login" class="md-trigger" data-modal="modal-3">[group=5]Войти[/group][not-group=5]Профиль[/not-group]</a></li>
<li><a href="[group=5]{registration-link}[/group][not-group=5]{logout-link}[/not-group]">[group=5]Регистрация[/group][not-group=5]Выйти[/not-group]</a></li>

<div class="md-modal md-effect-11" id="modal-3">
	<div class="md-content">
		<h3>[group=5]Авторизация[/group][not-group=5]пользователь: {login}[/not-group]</h3>
		<div class="userinfo" [group=5]style="min-height:100px;"[/group]>
			[group=5]
			<form action="" method="post" autocomplete="off">
				<div style="height:13px;"></div>
				<div class="leftCol" style="width:180px;">
						<input type="text" class="input" id="login_name" name="login_name" placeholder="Логин" />
						<input type="password" class="input" id="login_password" name="login_password" Placeholder="Пароль" />
				</div>
				<div class="rightCol">
					<button class="btn">Войти</button>
				</div>
				
				<input name="login" id="login" value="submit" type="hidden" />
			</form>
			[/group]
			[not-group=5]
				<div class="leftCol">
					<div class="avatar">
						<img src="{foto}" alt="{fullname}"/>
					</div>
				</div>
				<div class="rightCol">
					<ul class="proflink">
						[admin-link]<li><a href="/admin.php" target="_blank">Админпанель</a></li>[/admin-link]
						<li><a href="{profile-link}">Мой профиль</a></li>
						<li><a href="/?do=addnews">Добавить новость</a></li>
						<li><a href="/?do=pm">Сообщения ({all-pm}/{new-pm})</a></li>
						<li><a href="/?do=stats">Статистика</a></li>
					</ul>
				</div>
			[/not-group]
		</div>
	</div>
</div>
<div class="md-overlay"></div>

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Gameer

@Faik, в каком файле данный код?

O.T.

Список должен лежать в ul или в ol!

Да причем тут здесь это? Как не можете понять, тут не срабатывает обработка тегов, и все.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Faik

 

Faik, Вот попробуйте это:

Вот с этим кодом все ссылки работают. Но странно, что я мог пропустить? оО. Не первый раз делаю форму, и всегда все было нормально.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость Blendy

@Faik, =) почитай документацию)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Faik

Читал вроде, может упустил что. Просто я скопировал форму с другого моего сайта, где все прекрасно работает

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас

×
×
  • Создать...